miércoles, 22 de julio de 2009

Flex 3.3 y locale es_ES... por fin, Flex 3.3 en español!

Más de un lector me había pedido que crease la localización para la versión 3.3 (este SDK lleva un tiempo ya en el "mercado"). La verdad es que, no era consciente de que nadie la estuviese usando/esperando...

En el siguiente enlace FLEXSDK33-framework-locale-es_ES.zip
os dejo un .zip que podéis descomprimir en el directorio de vuestro Flex SDK 3.3 (primero creáis un directorio "es_ES" dentro del directorio "frameworks/locale" y luego copiáis allí los tres ficheros .swc que os dejo dentro del .zip) y simplemente añadiendo la siguiente opción al compilador "-locale es_ES" tendréis resuelto el asunto... al menos, el asunto español ;-)

También podéis modificar el fichero /frameworks/flex-config.xml para activar esta localización como la localización por defecto de vuestras compilaciones (es sencillo encontrar el lugar).

También podemos activar esta localización en el Flex Builder 3.0.2, que realmente utiliza un SDK que viene dentro del directorio "sdks" donde esté instalado este impresionante entorno de desarrollo.

Os dejo las versiones anteriores de estas "localizaciones" en:

3 comentarios:

dchamorros dijo...

Hola, tengo flex dsk 3.4 y la localizacion no me funciona sale


Unable to resolve resource bundle "datamanagement" for locale "es_ES".

Seria muy bueno si puedes explicar como se crea la estos archivos de localizacion.

Saludos

Wika2 dijo...

Hace tiempo publiqué un artículo sobre cómo yo creo estos archivos de localización.

Desde luego que no es exactamente como Adobe dice que se debe hacer, pero a mí me funciona.

Mira en Adobe Flex 3 Help en la sección "Advanced Flex Programming" y "Localizing Flex Applications", si quieres seguir las recomendaciones de Adobe.

Con respecto al error del "datamanagement" es porque yo no localizo esos recursos (creo que pertenecen a la parte comercial del Flex Builder que yo no poseo).

Sólo traslado la parte "abierta" del SDK de Flex. Puedes intentar ver qué .swc de tu carpeta "en_US" tienes que yo no te proporciono y copiarlos (junto con los míos) en la carpeta "es_ES".

Anónimo dijo...

Eso tampoco funciona, lo hice ya el resource blunde charts no me funciona y me dá el sgte error:
Unable to resolve resource bundle "charts" for locale "es_ES".